AWS Outage - 10/20/2025

Incident Report for MarketWise Solutions

Resolved

AWS has confirmed that the incident is resolved. MWS Team will continue to monitor our systems and performance.
Posted Oct 20, 2025 - 13:58 EDT

Update

MWS has noticed some systems recovering and we are continuing to monitor all tools and order forms.
Posted Oct 20, 2025 - 13:02 EDT

Investigating

AWS is currently experiencing a performance degradation/outage across its platform. We have not observed any issues with accepting and processing orders but we could encounter a delay with this information loading into Zuora/Salesforce. It is possible that we encounter delays in reporting data while our tools/features are recovering.
Posted Oct 20, 2025 - 09:15 EDT
This incident affected: Reporting / Analytics (Looker, Tableau) and IT Operations Systems (AWS).