Cloudflare has resolved this incident. All systems are functioning appropriately.
Posted Nov 18, 2025 - 14:34 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 14:33 EST
Monitoring
Cloudflare provided an update at 9:42 AM that a fix was implemented and the incident was considered resolved.
We have seen our services start to resolve. We will continue to monitor this and ensure everything is back up and running.
Posted Nov 18, 2025 - 10:12 EST
Identified
Cloudflare identified an issue which impacts multiple customers: Widespread 500 errors, Cloudflare Dashboard and API also failing.
They are currently working to fix this issue as it is global and impacting any customer who uses Cloudflare.
We will continue to monitor their updates but please note we are seeing 500 errors in Salesforce, websites are not loading, etc. We will provide updates as soon as we have them.
Posted Nov 18, 2025 - 08:34 EST
This incident affected: Salesforce.com (Account Maintenance / Creation).