All Batch mode orders have been processed. This issue is now resolved, and we will post a root cause analysis from Zuora when it becomes available.
Posted Sep 09, 2025 - 20:38 EDT
Monitoring
Zuora has recovered, and we are now out of Batch mode. We will process all orders captured in Batch this afternoon, and provide additional information on root cause once we receive it from Zuora.
Posted Sep 09, 2025 - 14:52 EDT
Update
Zuora engineers are still investigating the issue. We will provide another update by 3:30pm EST, if not sooner.
Posted Sep 09, 2025 - 14:18 EDT
Investigating
We are currently experiencing an influx in Zuora errors, resulting in slowness/missing data in the Salesforce UI and online order errors. As a result, we have moved into Batch mode.
Affiliates Impacted: All
What does this mean? Batch mode means that we are recording details of online orders, but subscriptions, invoices and payments are not being created/processed in Salesforce or our billing/payment processing platforms (Checkout, Zuora, Vantiv). Impact to customers is minimal, as confirmation emails are still sent and web access is granted. Any subscriptions captured during this maintenance period will be created via an automated process when we turn off batch mode.