Salesforce APEX Errors - Batch Mode - 5/21/26

Incident Report for MarketWise Solutions

Resolved

All offline orders have been processed. We will provide additional details regarding the incident as they become available.
Posted May 15, 2026 - 07:29 EDT

Monitoring

The rollback has completed and Salesforce has confirmed the issue is resolved. They will fully investigate the incident, confirming the technical trigger, the underlying cause, and preventive action to avoid a repeat in the future.

We are back online and will process all orders captured while offline/batch this evening. We will continue to monitor performance and remain in close contact with CS/TS Managers regarding any failed orders.
Posted May 14, 2026 - 16:49 EDT

Identified

The issue has been linked to a recent Salesforce prediction service deployment. Salesforce Support confirmed that mitigation efforts are currently underway, including a rollback to the previous stable version. Both MWS and Salesforce teams are actively monitoring service recovery and customer impact.

We will remain in batch/offline mode until the incident is resolved.
Posted May 14, 2026 - 15:54 EDT

Investigating

Affiliates Impacted: All

What does this mean? Batch mode means that we are recording details of online orders, but subscriptions, invoices and payments are not being created/processed in Salesforce or our billing/payment processing platforms (Payment Processors, Zuora). Impact to customers is minimal, as confirmation emails are still sent and web access is granted. Any subscriptions captured during this maintenance period will be created via an automated process when we turn off batch mode.

Check out our Batch Mode FAQ: https://beaconstreetservices.atlassian.net/wiki/spaces/ITKB/pages/70968180753/Batch+Mode+Process+FAQ

Daily reporting will be impacted depending on the day/time the orders are processed.
Posted May 14, 2026 - 14:40 EDT
This incident affected: Order Processing.